Click here to register.

General Discussion

Flat
HVite ERROR [+6006]
User: kiguaran001
Date: 11/28/2016 6:01 am
Views: 3831
Rating: 0

Hi guys, Im trying to run the recogniser live, and Im using the following command:

bin/HVite -H modeloak/hmm9/makro -H modeloak/hmm9/hmmdefs -C konfigurazioak/HVite.config -w wdnet -p 0.0 -s 5.0 phones.dict phones.list1

HVite.config file:

SOURCERATE=625.0
SOURCEKIND=HAUDIO
SOURCEFORMAT=HTK
ENORMALISE=F
USESILDET=T
MEASURESIL=F
OUTSILWARN=T
TARGETKIND = MFCC_0_D_A
WINDOWSIZE = 250000.0
TARGETRATE = 100000.0

I added the last 3 lines because of another error, and adding this lines solutioned that error.

I also tried changing SOURCEFORMAT from HTK to WAV but I got the same error message.

Please I need ayour help, I will be glad to read any answer or suggestion.

Kepa

--- (Edited on 11/28/2016 6:01 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: nsh
Date: 11/28/2016 6:50 am
Views: 19
Rating: 0

It is not quite clear what is the problem you have.

--- (Edited on 11/28/2016 15:50 [GMT+0300] by nsh) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 11/28/2016 10:55 am
Views: 18
Rating: 0

Im sorry part of the message had been deleted.

well, this is the error message I got after trying to run HVite with the command I Wrote in the first message:

READY[1]>
  ERROR [+6006]  InitAudi: Cannot open OSS audio device /dev/dsp

And as I said in the first message, I tried to run HVite also changing WAVEFORMAT, from HTK to WAV, but it didnt work, I got the same error.

I tried to solve this error installing oss-compat like this:

Code:

sudo apt-get install oss-compat

But the error remains.

What would you try to do?

--- (Edited on 11/28/2016 10:55 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: nsh
Date: 11/28/2016 11:05 am
Views: 32
Rating: 0

oss-compat is complicated, it requires kernel driver to be loaded which might be tricky.

The easiest way if you already have pulseaudio working would be to use padsp command https://linux.die.net/man/1/padsp

Simply run

padsp bin/HVite -H modeloak/hmm9/makro -H modeloak/hmm9/hmmdefs -C konfigurazioak/HVite.config -w wdnet -p 0.0 -s 5.0 phones.dict phones.list1

--- (Edited on 11/28/2016 20:05 [GMT+0300] by nsh) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 11/29/2016 5:54 am
Views: 100
Rating: 0

It doesnt work, I have installed pulseaudio as you said and try the command you suggested to me but I got the same error message.

It looks like I cant play videos in youtube for example or song or recordings, I cant play nothing.

What do you suggest me to do?

--- (Edited on 11/29/2016 5:54 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 11/30/2016 2:40 am
Views: 15
Rating: 0

Kepa, one thing you could consider is to use the speech recognizer Julius (https://github.com/julius-speech/julius) which reads HTK models and can be compiled with pulseaudio as an option, which gets you away from /dev/* specification of audio devices. The downside is that there is more to compile, but the upside is a slightly freer license.

--- (Edited on 2016-11-30 3:40 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 12/1/2016 5:22 am
Views: 22
Rating: 0

I have installed Julius, but when I try to run it live, nothing happens.

What I mean is that when I write this command:

~/julius-4.2.2$ padsp julius -C julius.conf
STAT: include config: julius.conf
kepa@kepa-VirtualBox:~/julius-4.2.2$

As you can see nothing happened, the <<SPEAK>> command doesnt appear.

Do you know why?

--- (Edited on 12/1/2016 5:22 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/1/2016 6:13 am
Views: 21
Rating: 0

There must be something incomplete about your julius configuration. This is what I see when I run Julius:

colin@linux-tqr4:~/vox/alice> julius -C al.jconf
STAT: include config: al.jconf
STAT: jconf successfully finalized

and this is followed by extensive reporting by Julius about the settings it has recognized. You do not report the line "successfully finalized" so your first goal is to see it. One thing is to compare your jconf file with the standard Voxforge jconf that Ken recommends for the tutorial (see the "Develop" link.) The jconf is complicated, compare carefully, the activated options have an enormous impact on the result.

As a further check, here is what configure tells me in response to:

$ ./configure --prefix=/usr --with-mictype=pulseaudio

- Audio I/O
    primary mic device API   : pulseaudio (PulseAudio)
    available mic device API : pulseaudio
    supported audio format   : various formats by libsndfile ver.1
    NetAudio support         : no
- Language Modeling
    class N-gram support     : yes
- Libraries
    file decompression by    : zlib library
- Process management
    fork on adinnet input    : no

Check that you see similar output.

--- (Edited on 2016-12-01 7:13 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: Visitor
Date: 12/1/2016 11:04 am
Views: 14
Rating: 0

I tried the command you suggested me to check the response and I got this response whith an error:

~/julius-4.2.2$ ./configure --prefix=/usr --with-mictype=pulseaudio
loading cache ./config.cache
checking host system type... x86_64-unknown-linux
checking host specific optimization flag... no
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for rm... (cached) /bin/rm
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
creating ./config.status
creating Makefile
creating mkbingram/Makefile
creating mkbinhmm/Makefile
creating adinrec/Makefile
creating adintool/Makefile
creating mkss/Makefile
creating generate-ngram/Makefile
creating jclient-perl/Makefile
creating man/Makefile
configuring in mkgshmm
running /bin/sh ./configure  --prefix=/usr --with-mictype=pulseaudio --cache-file=.././config.cache --srcdir=.
loading cache .././config.cache
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for rm... (cached) /bin/rm
checking for perl... (cached) /usr/bin/perl
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
creating ./config.status
creating Makefile
creating mkgshmm
configuring in gramtools
running /bin/sh ./configure  --prefix=/usr --with-mictype=pulseaudio --cache-file=.././config.cache --srcdir=.
loading cache .././config.cache
checking host system type... x86_64-unknown-linux
checking host-specific optimization flag... no
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
checking host specific optimization flag... skipped
checking for rm... (cached) /bin/rm
checking for perl... (cached) /usr/bin/perl
checking for iconv... (cached) /usr/bin/iconv
checking for Jcode module in perl... Can't locate Jcode.pm in @INC (you may need to install the Jcode module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.2 /usr/local/share/perl/5.22.2 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .).
BEGIN failed--compilation aborted.
configure: warning: no Jcode module in perl, gram2sapixml.pl may not work
checking for readline/readline.h... (cached) no
checking for malloc.h... (cached) yes
creating ./config.status
creating Makefile
creating mkdfa/Makefile
creating mkdfa/mkdfa.pl
creating mkdfa/mkfa-1.44-flex/Makefile
creating dfa_minimize/Makefile
creating generate/Makefile
creating accept_check/Makefile
creating nextword/Makefile
creating yomi2voca/Makefile
creating yomi2voca/yomi2voca.pl
creating gram2sapixml/Makefile
creating gram2sapixml/gram2sapixml.pl
creating dfa_determinize/Makefile
configuring in jcontrol
running /bin/sh ./configure  --prefix=/usr --with-mictype=pulseaudio --cache-file=.././config.cache --srcdir=.
loading cache .././config.cache
checking host system type... x86_64-unknown-linux
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for rm... (cached) /bin/rm
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
checking for gethostbyname... (cached) yes
checking for connect... (cached) yes
creating ./config.status
creating Makefile
configuring in julius
running /bin/sh ./configure  --prefix=/usr --with-mictype=pulseaudio --cache-file=.././config.cache --srcdir=.
loading cache .././config.cache
checking host system type... x86_64-unknown-linux
checking host-specific optimization flag... no
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for rm... (cached) /bin/rm
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
checking for ANSI C header files... (cached) yes
checking for working const... (cached) yes
checking for winnls.h... (cached) no
checking for iconv... (cached) yes
checking for iconv declaration... (cached)
         extern size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
checking for charset conversion... iconv
creating ./config.status
creating Makefile
creating config.h
config.h is unchanged
configuring in libjulius
running /bin/sh ./configure  --prefix=/usr --with-mictype=pulseaudio --cache-file=.././config.cache --srcdir=.
loading cache .././config.cache
checking host system type... x86_64-unknown-linux
checking host-specific optimization flag... no
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for rm... (cached) /bin/rm
checking for ar... (cached) /usr/bin/ar
checking for ranlib... (cached) ranlib
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
checking for ANSI C header files... (cached) yes
checking for working const... (cached) yes
checking return type of signal handlers... (cached) void
checking for dlopen... (cached) no
checking for dlopen in -ldl... (cached) yes
checking for POSIX thread library in -lpthread... yes
creating ./config.status
creating Makefile
creating libjulius-config
creating libjulius-config-dist
creating src/version.c
creating doxygen.conf.ver
creating include/julius/config.h
include/julius/config.h is unchanged
configuring in libsent
running /bin/sh ./configure  --prefix=/usr --with-mictype=pulseaudio --cache-file=.././config.cache --srcdir=.
loading cache .././config.cache
checking host system type... x86_64-unknown-linux
checking host specific optimization flag... no
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for rm... (cached) /bin/rm
checking for ar... (cached) /usr/bin/ar
checking for ranlib... (cached) ranlib
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
checking for ANSI C header files... (cached) yes
checking for unistd.h... (cached) yes
checking whether byte ordering is bigendian... (cached) no
checking for working const... (cached) yes
checking for socklen_t... yes
checking for gethostbyname... (cached) yes
checking for connect... (cached) yes
checking for strcasecmp... (cached) yes
checking for sleep... (cached) yes
checking for alsa/asoundlib.h... (cached) no
checking for sys/asoundlib.h... (cached) no
checking for sys/soundcard.h... (cached) yes
checking for esd.h... (cached) no
checking for pa_simple_new in -lpulse-simple... (cached) no
configure: error: no PulseAudio header!
configure: error: ./configure failed for libsent

I think it means I havent installed pulseaudio properly, am I right?

And can you suggest me a way to install pulseaudio properly, because a tried diferent ways but Im getting the same error

--- (Edited on 12/1/2016 11:04 am [GMT-0600] by Visitor) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/1/2016 11:41 am
Views: 11
Rating: 0

Check to see that you have the pulseaudio development files installed. On my system the package is called "libpulse-devel" but it might have a different name on your setup.

--- (Edited on 2016-12-01 12:41 pm [GMT-0500] by colbec) ---

PreviousNext