Click here to register.

General Discussion

Nested
HVite ERROR [+6006]
User: kiguaran001
Date: 11/28/2016 6:01 am
Views: 4415
Rating: 0

Hi guys, Im trying to run the recogniser live, and Im using the following command:

bin/HVite -H modeloak/hmm9/makro -H modeloak/hmm9/hmmdefs -C konfigurazioak/HVite.config -w wdnet -p 0.0 -s 5.0 phones.dict phones.list1

HVite.config file:

SOURCERATE=625.0
SOURCEKIND=HAUDIO
SOURCEFORMAT=HTK
ENORMALISE=F
USESILDET=T
MEASURESIL=F
OUTSILWARN=T
TARGETKIND = MFCC_0_D_A
WINDOWSIZE = 250000.0
TARGETRATE = 100000.0

I added the last 3 lines because of another error, and adding this lines solutioned that error.

I also tried changing SOURCEFORMAT from HTK to WAV but I got the same error message.

Please I need ayour help, I will be glad to read any answer or suggestion.

Kepa

--- (Edited on 11/28/2016 6:01 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: nsh
Date: 11/28/2016 6:50 am
Views: 19
Rating: 0

It is not quite clear what is the problem you have.

--- (Edited on 11/28/2016 15:50 [GMT+0300] by nsh) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 11/28/2016 10:55 am
Views: 18
Rating: 0

Im sorry part of the message had been deleted.

well, this is the error message I got after trying to run HVite with the command I Wrote in the first message:

READY[1]>
  ERROR [+6006]  InitAudi: Cannot open OSS audio device /dev/dsp

And as I said in the first message, I tried to run HVite also changing WAVEFORMAT, from HTK to WAV, but it didnt work, I got the same error.

I tried to solve this error installing oss-compat like this:

Code:

sudo apt-get install oss-compat

But the error remains.

What would you try to do?

--- (Edited on 11/28/2016 10:55 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: nsh
Date: 11/28/2016 11:05 am
Views: 32
Rating: 0

oss-compat is complicated, it requires kernel driver to be loaded which might be tricky.

The easiest way if you already have pulseaudio working would be to use padsp command https://linux.die.net/man/1/padsp

Simply run

padsp bin/HVite -H modeloak/hmm9/makro -H modeloak/hmm9/hmmdefs -C konfigurazioak/HVite.config -w wdnet -p 0.0 -s 5.0 phones.dict phones.list1

--- (Edited on 11/28/2016 20:05 [GMT+0300] by nsh) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 11/29/2016 5:54 am
Views: 115
Rating: 0

It doesnt work, I have installed pulseaudio as you said and try the command you suggested to me but I got the same error message.

It looks like I cant play videos in youtube for example or song or recordings, I cant play nothing.

What do you suggest me to do?

--- (Edited on 11/29/2016 5:54 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 11/30/2016 2:40 am
Views: 15
Rating: 0

Kepa, one thing you could consider is to use the speech recognizer Julius (https://github.com/julius-speech/julius) which reads HTK models and can be compiled with pulseaudio as an option, which gets you away from /dev/* specification of audio devices. The downside is that there is more to compile, but the upside is a slightly freer license.

--- (Edited on 2016-11-30 3:40 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 11/30/2016 4:29 am
Views: 13
Rating: 0

Hi again, I tried again the same command and I noticed that the error message is a bit different than before:

padsp bin/HVite -H modeloak/hmm9/makro -H modeloak/hmm9/hmmdefs -C konfigurazioak/HVite.config -w wdnet -p 0.0 -s 5.0 phones.dict phones.list1
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

READY[1]>
  ERROR [+6006]  InitAudi: Cannot open OSS audio device /dev/dsp
 FATAL ERROR - Terminating program bin/HVite

It looks like I need a lib or something like that. What do you think about?

Kepa

--- (Edited on 11/30/2016 4:29 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 11/30/2016 4:34 am
Views: 99
Rating: 0

Kepa, if you do a google search on "pulseaudio preloaded wrong elf class" you will hit a number of items that talk about this issue. It may have something to do with 64 and 32 bit. See if you see anything that makes sense in your context.

--- (Edited on 2016-11-30 5:34 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 12/1/2016 5:22 am
Views: 22
Rating: 0

I have installed Julius, but when I try to run it live, nothing happens.

What I mean is that when I write this command:

~/julius-4.2.2$ padsp julius -C julius.conf
STAT: include config: julius.conf
kepa@kepa-VirtualBox:~/julius-4.2.2$

As you can see nothing happened, the <<SPEAK>> command doesnt appear.

Do you know why?

--- (Edited on 12/1/2016 5:22 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/1/2016 6:13 am
Views: 21
Rating: 0

There must be something incomplete about your julius configuration. This is what I see when I run Julius:

colin@linux-tqr4:~/vox/alice> julius -C al.jconf
STAT: include config: al.jconf
STAT: jconf successfully finalized

and this is followed by extensive reporting by Julius about the settings it has recognized. You do not report the line "successfully finalized" so your first goal is to see it. One thing is to compare your jconf file with the standard Voxforge jconf that Ken recommends for the tutorial (see the "Develop" link.) The jconf is complicated, compare carefully, the activated options have an enormous impact on the result.

As a further check, here is what configure tells me in response to:

$ ./configure --prefix=/usr --with-mictype=pulseaudio

- Audio I/O
    primary mic device API   : pulseaudio (PulseAudio)
    available mic device API : pulseaudio
    supported audio format   : various formats by libsndfile ver.1
    NetAudio support         : no
- Language Modeling
    class N-gram support     : yes
- Libraries
    file decompression by    : zlib library
- Process management
    fork on adinnet input    : no

Check that you see similar output.

--- (Edited on 2016-12-01 7:13 am [GMT-0500] by colbec) ---

PreviousNext