Click here to register.

General Discussion

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 12/15/2016 2:05 am
Views: 14
Rating: 0

Hi! I managed to compile julius-4.2.2, as nsh said I untared again julius 4.2.2 and it worked, this is the comand and the response i got:

./configure --prefix=/usr --with-mictype=pulseaudio

Julius/Julian libsent library rev.4.2.2:

- Audio I/O
    primary mic device API   : pulseaudio (PulseAudio)
    available mic device API : pulseaudio
    supported audio format   : RAW and WAV only
    NetAudio support         : no
- Language Modeling
    class N-gram support     : yes
- Libraries
    file decompression by    : zlib library
- Process management
    fork on adinnet input    : no
  Note: compilation time flags are now stored in "libsent-config".
        If you link this library, please add output of
        "libsent-config --cflags" to CFLAGS and
        "libsent-config --libs" to LIBS.

I supose its correctly compiled.

But when I try to run Julius it doesnt do nothing again:

~/julius-4.2.2$ julius -C julius.conf
STAT: include config: julius.conf
~/julius-4.2.2$ julius -C julius.conf3
STAT: include config: julius.conf3

As you can see I tried to run it with different conf files.


--- (Edited on 12/15/2016 2:06 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/15/2016 2:39 am
Views: 22
Rating: 0

Configure by itself will not compile Julius, did you do make and make install?

You should be careful, you possibly now have different working versions of Julius on your system and you should be sure in testing which version you are actually running by using the full path.

Did you try the suggestion to run Julius with the -debug option?

--- (Edited on 2016-12-15 3:39 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: Visitor
Date: 12/15/2016 10:55 am
Views: 14
Rating: 0

yes I also have done make and make install and it doesnt give me any error, can it be because of the microphone or something like that? Because I managed to hear my wav recordings but audacity is not working and my supposition is that it can be because of I cant record nothing.

Yes I tried the -debug option in my recently installed julius and this is the answer:

~/julius-4.2.2$ julius -debug -C julius.jconf
STAT: include config: julius.jconf
DEBUG: args: -dfa sample.dfa -v sample.dict -h hmm15/hmmdefs -hlist tiedlist -smpFreq 16000 -spmodel sp -multipath -gprune safe -iwcd1 max -iwsppenalty -70.0 -iwsp -penalty1 5.0 -penalty2 20.0 -b2 200 -sb 200.0 -n 1 -lv 4000 -logfile julius.log -quiet

But I have realised that I have done a big mistake, because, I was using the grammar of HTK and with JULIUS I have to use another grammar. Im going to try it with the new grammar and i will tell you about.

--- (Edited on 12/15/2016 10:55 am [GMT-0600] by Visitor) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 12/16/2016 5:52 am
Views: 30
Rating: 0

I have made the grammar using julius but i have another question: I havent got to use triphonemes because my system doesnt need it, so do you know what I have to write in this config options? and are there other options I have to change because im not using triphonemes?

-hlist tiedlist # HMMList to map logical phone to physical
-iwcd1 max # Inter-word triphone approximation method

I spect that in hlist option i have to put my phone list but im not sure.

I have installed JULIA and I used it to make the JULIUS grammar and to do that it needs some binnaries from JULIUS and it worked well so I supose that I have got installed JULIUS

--- (Edited on 12/16/2016 5:52 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/16/2016 6:36 am
Views: 118
Rating: 0

Kepa, this thread is about getting a speech recognizer working. We started out with problems with HVite and have moved over to Julius. If you are convinced that Julius is working then this thread has ended and anything new needs to be in its own thread.

Note 1: Julius comes with a number of standalone utilities to do various things. Just because one or two of the utilities has successfully compiled and works does not tell you anything about how well Julius works.

Note 2: An efficient way to check whether Julius is working is to run through Ken's excellent tutorial (see the "Develop" section on this site) for HTK/Julius to build a very basic model and get used to the kinds of things that HTK and Julius need when doing actual recognition. These tutorials have been discussed and refined by people from many different countries and lots of the bugs have been worked out. It is a reliable check that all the components for building and recognition are working. Once you have the most simple models working, then you can move on to tweaking the model and its generation to suit your own requirements.

--- (Edited on 2016-12-16 7:36 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 12/17/2016 5:50 am
Views: 529
Rating: 0

Thats true you are right, I will open another thread if I have any problem.

I understand what you say about JULIUS, but until now it is working well.

Okay I will try to do the tutorials to check if it works well or not, but I said that I didnt need the triphones because my boss told me that for my project I wasnt going to need them because the results were going to be worse.

So i will also try to run JULIUS without triphones.

--- (Edited on 12/17/2016 5:50 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 11/30/2016 4:29 am
Views: 13
Rating: 0

Hi again, I tried again the same command and I noticed that the error message is a bit different than before:

padsp bin/HVite -H modeloak/hmm9/makro -H modeloak/hmm9/hmmdefs -C konfigurazioak/HVite.config -w wdnet -p 0.0 -s 5.0 phones.dict phones.list1
ERROR: object '/usr/lib/x86_64-linux-gnu/pulseaudio/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

  ERROR [+6006]  InitAudi: Cannot open OSS audio device /dev/dsp
 FATAL ERROR - Terminating program bin/HVite

It looks like I need a lib or something like that. What do you think about?


--- (Edited on 11/30/2016 4:29 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 11/30/2016 4:34 am
Views: 105
Rating: 0

Kepa, if you do a google search on "pulseaudio preloaded wrong elf class" you will hit a number of items that talk about this issue. It may have something to do with 64 and 32 bit. See if you see anything that makes sense in your context.

--- (Edited on 2016-11-30 5:34 am [GMT-0500] by colbec) ---