Click here to register.

General Discussion

Flat
Re: HVite ERROR [+6006]
User: colbec
Date: 12/13/2016 6:20 am
Views: 91
Rating: 0

The idea is simply to read in your jconf file, read each line, and if the first character is a "#" then ignore it, but if it is "-" then report it.

Regarding a choice of distro, keep your options open. If you continue to have problems with HTK/Julius you might be tempted to go with the speech package Sphinx (https://en.wikipedia.org/wiki/CMU_Sphinx) which is the specialty of contributor nsh who as you have seen, has tried to help you before. So perhaps Dr. Nickolay S. has a suggestion for a distro, then you are in a good place to change horses.

--- (Edited on 2016-12-13 7:20 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: Visitor
Date: 12/13/2016 1:51 pm
Views: 3
Rating: 0

Hi again!

No I have to use HTK, because im suposed to do my proyect using it. I have problems with all items which are related to the sound(also audacity, I cant record nothing) so I think I have make an error while installing the virtual machine. I will try to install another and see if the sound works.

--- (Edited on 12/13/2016 1:51 pm [GMT-0600] by Visitor) ---

Re: HVite ERROR [+6006]
User: nsh
Date: 12/13/2016 4:10 pm
Views: 81
Rating: 0

Sound should work fine in a virtual machine. Ubuntu 16.10 is OK distribution.

 

--- (Edited on 12/14/2016 01:10 [GMT+0300] by nsh) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/14/2016 4:51 am
Views: 3
Rating: 0

I had another thought on testing Julius. By selecting the right input mode in the jconf file it should be possible to test whether your already loaded, precompiled Julius is working by not using the microphone but reading an existing file. If you activate the option "-input rawfile" and deactivate the other input options by commenting them out with "#" then Julius on launch should load up and present you with the prompt "### read waveform input
enter filename->" It will wait there for you to type in the name of a wave file and when you press return will scan that file and try to decode the content to text. It's a test which does not depend on the audio system, where you seem to have some issues.

--- (Edited on 2016-12-14 5:51 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/14/2016 5:08 am
Views: 5
Rating: 0

A second thought. Run your precompiled Julius with the option -debug. This will present a lot more information about your Julius startup which will be informative. On my system it starts:

> julius -debug -C al.raw.jconf
STAT: include config: al.raw.jconf
DEBUG: args: -input rawfile -nostrip -lv 2000 -tailmargin 400 -rejectshort 50 -dfa al.dfa -v al.dict -h acoustic_model_files/hmmdefs -hlist acoustic_model_files/tiedlist -spmodel sp -multipath -gprune safe -iwcd1 max -iwsppenalty -70.0 -smpFreq 16000 -penalty2 20.0 -b2 200 -sb 80.0 -n 1
STAT: jconf successfully finalized
------------------------------------------------------------
Configuration of Modules

 Number of defined modules: AM=1, LM=1, SR=1

 Acoustic Model (with input parameter spec.):
....

--- (Edited on 2016-12-14 6:08 am [GMT-0500] by colbec) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 12/7/2016 4:39 am
Views: 4
Rating: 0

Hi nsh!

The config.log file looks like this:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:555: checking host system type
configure:577: checking host specific optimization flag
configure:593: checking for gcc
configure:706: checking whether the C compiler (gcc  ) works
configure:722: gcc -o conftest    conftest.c  1>&5
configure:719:1: warning: return type defaults to 'int' [-Wimplicit-int]
 main(){return(0);}
 ^~~~
configure:748: checking whether the C compiler (gcc  ) is a cross-compiler
configure:753: checking whether we are using GNU C
configure:781: checking whether gcc accepts -g
configure:813: checking how to run the C preprocessor
configure:904: checking for a BSD compatible install
configure:959: checking for rm
configure:992: checking for Cygwin environment
configure:1025: checking for mingw32 environment
configure:1056: checking for executable suffix

But I cant see nothing related to my error, what do you think? should I install again from the begining another linux as a virtual machine?

--- (Edited on 12/7/2016 4:39 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: nsh
Date: 12/13/2016 4:08 pm
Views: 5
Rating: 0

You need to share the config.log file, not part of it. You can share over dropbox/google drive.

 

--- (Edited on 12/14/2016 01:08 [GMT+0300] by nsh) ---

Re: HVite ERROR [+6006]
User: kiguaran001
Date: 12/14/2016 3:47 am
Views: 9
Rating: 0

 Here you have the link to the file:

 https://drive.google.com/drive/folders/0Byv7VrqABsRBUEhDamFMS09FUGs?usp=sharing

 

--- (Edited on 12/14/2016 3:47 am [GMT-0600] by kiguaran001) ---

--- (Edited on 12/14/2016 3:50 am [GMT-0600] by kiguaran001) ---

Re: HVite ERROR [+6006]
User: nsh
Date: 12/14/2016 6:20 am
Views: 11
Rating: 0

I think you need to solve jconf problem with precompiled binary discussed above first, then you might return to this issue.

This problematic log seems due to the fact you corrupted configure with autoreconf, you probably need to unpack clean sources once again. Real log should be much longer.

 

--- (Edited on 12/14/2016 15:20 [GMT+0300] by nsh) ---

Re: HVite ERROR [+6006]
User: colbec
Date: 12/14/2016 6:45 am
Views: 14
Rating: 0

Just a note here to say that I can run autoreconf on my system before running ./configure ... and it does not have an adverse effect on the configure process which runs correctly. So the reason for the truncated output might be something else.

Do we have the right log? FWIW my config.log output starts with:

## ----------------- ##
## Output variables. ##
## ----------------- ##

CC='gcc'
CFLAGS='-O6 -fomit-frame-pointer'
CPP='gcc -E'

.......

--- (Edited on 2016-12-14 7:45 am [GMT-0500] by colbec) ---

PreviousNext