Click here to register.

Dutch

Flat
Acoustic model in Sphinx 4
User: Visitor
Date: 1/19/2009 12:32 am
Views: 14643
Rating: 16

There is no error when i run Sphinxtrain.but when i run the command

perl scripts_pl/decode/slave.pl     

                (In ncst(our own database) packege like an4) then i m getting error

Error..

Configuration (e.g. etc/sphinx_train.cfg) not defined
Compilation failed in require at scripts_pl/decode/slave.pl line 45.
BEGIN failed--compilation aborted at scripts_pl/decode/slave.pl line 45.

Please help me out

 

Re: Acoustic model in Sphinx 4
User: nsh
Date: 1/19/2009 1:34 am
Views: 1071
Rating: 14

I think it clearly tells you that configuration file etc/sphinx_train.cfg is missing.

Re: Acoustic model in Sphinx 4
User: anonymous
Date: 6/5/2009 8:38 am
Views: 133
Rating: 15

Hey dude


I too get the same error but the configuration file etc/sphinx_train.cfg is present. Do you know what else might be causing the problem? I am using the following sphinx version

sphinx3-0.6.3

 

Thanks a lot.

 

Re: Acoustic model in Sphinx 4
User: anonymous
Date: 6/5/2009 9:34 am
Views: 235
Rating: 17

I think I might know the problem, but I am not quite sure. I just found out that I am missing a sphinx_decode.cfg in my etc folder and that might be the issue. I dont know why isnt it present in the first place but any help regarding this would be really appreciated. I have also uploaded my complete task so far and can be accessed by the following link.

http://www.mediafire.com/?bcznqxktdxz

Please do tell me what is wrong. Waiting for your reply.


Thanks Smile

Re: Acoustic model in Sphinx 4
User: nsh
Date: 6/6/2009 8:02 am
Views: 158
Rating: 16

You forgot to setup the decoder as described in tutorial.

 

Re: Acoustic model in Sphinx 4
User: hozefa26
Date: 6/7/2009 4:01 pm
Views: 157
Rating: 16

Hey nsh

 

Thanks for the reply Smile. By decoder, do you mean "sphinxbase". I am a little confused by your reply. Could you please be a little more explicit. Waiting for your quick reply.

 

Cheers


Hozefa

Re: Acoustic model in Sphinx 4
User: hozefa26
Date: 6/8/2009 3:31 am
Views: 170
Rating: 15

ok .. firstly i had uploaded the wrong task.

secondly i found my sphinx_decode.cfg

but i have a new problem now... when i perform a preliminary decode and i run

perl scripts_pl/decode/slave.pl

 

i have the following error

UHR-Hozefa@Perm:~/Desktop/SR/an4$ perl scripts_pl/decode/slave.pl
Can't locate /home/UHR-Hozefa/Desktop/SR/an4/scripts_pl/util/utils.pl in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at etc/sphinx_decode.cfg line 23.
Compilation failed in require at scripts_pl/decode/slave.pl line 52.


Waiting for your esteemed adviced.

Cheers


Hozefa

Re: Acoustic model in Sphinx 4
User: kmaclean
Date: 6/10/2009 12:02 pm
Views: 3532
Rating: 14

Have you followed all the steps in the CMU Robust Group Tutorial (Learning to use the CMU SPHINX Automatic Speech Recognition system)?

Ken

Re: Acoustic model in Sphinx 4
User: kkrasika
Date: 4/24/2011 10:26 pm
Views: 184
Rating: 16

Hi 

I'm facing the same problem as you "missing a sphinx_decode.cfg in my etc folder"

I'm too cannot find it inside  sphinxtrain-1.0.7/etc/ folder.
Here you have stated you could find it. Please let me know where it is.

Thanx in advance 

 

Re: Acoustic model in Sphinx 4
User: kmaclean
Date: 4/25/2011 9:50 am
Views: 741
Rating: 11
PreviousNext